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1 An Introduction toData Analysis

Astronomy and Data

Astronomy has always been a data-driven discipline. From the earliest civilisations to the very bleeding edge of
21st-century humanity, data has been the core of thematter. Humans have obtained and processed data; we have
analysed andmade conclusions from said data to learn more about the world and the universe we live in.

In themodern era of data-driven astronomy, no observation method has transformed the field as much as imaging.
Needless to say, our astronomy knowledge is highly dependent on the availability and quality of data we can gather
about the night sky; breakthroughs in modern astronomy often follow novel, eye-opening data. Imaging is at the
core of data collection in astronomy, so much of the information we can gather about our universe comes in the
form of electromagnetic radiation and photons.

But why limit us to what we can see? With different filters and imaging devices, we can look at the universe through
a totally different set of eyes. False Colour images of objects representing wavelengths outside the visible spectrum

allow us to see what we cannot see.

To help us explore the various images taken by various telescopes and sky surveys, we will be using a tool called
SAOImageDS9, download the software here.

You are highly encouraged to learn more about controls in SAOImageDS9 in the Appendix before you proceed with
the question.

About the Data Analysis Question

A question completely dedicated to data analysis in this form was introduced since AstroChallenge 2020. In the
continued spirit of learning, you might find some parts to be rather guided—this is intentional. However, others will
require you to think out of the box, and be resourceful with the data source.

This question is meant to replace one of the five questions in the Team Round, so themaximum number ofmarks in
this entire round will be 20. Exact mark allocations will be given within the right margin next to each part orsub-part,
in boldface and in square brackets, like such: [2].

You are allowed to reference external sources to help you in answering the questions. However, note that copying
from sources without apparent synthesis or evaluation will be penalised. Every item that you submit must be of your
own work; cite any external references as needed. Failure to do so will be penalised.

Deliverables

This section outlines the deliverables to be submitted for the data analysis question. Everything in the following list
is to be submitted—any omissions will lead to your team losing marks.

• A .fits file containing your response to Question 1.d) <Your school abbreviation>_T<your team

number>_1d.fits (In other words, if you are in Team 1 from Astro Challenge Secondary School, please label
your response as ACSS_T1_1d.fits);

• A type-written report in.pdf formatnamed<Your school abbreviation>_T<your team number>_Report.pdf,
which should include:

– Your team’s attempts for all questions;

– A bibliography, if any external sources were used and cited;

– An appendix, with all your graphs and images
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2 X

1. Open up SAOImageDS9. Under Analysis in themenu bar, select Virtual Observatory. Check Rutgers
X-ray Analysis Server #2, as shown in Fig. 1.

Figure 1: Virtual Observatory pop-up window

Figure 2: Rutgers X-ray Analysis Server #2 page

Once the page loads (Fig. 2), click on the first link ACIS OBSERVATION OF CAS A (first 5K seconds only).
This will load the image from the observation into your main window in DS9. Once we have the image, we can
also change its colour. Let’s increase the contrast by changing the colour from grey to bb under Color in the
buttons bar. You should see something like this (Fig. 3).

Change the scale by going to the Scale menu or scale button and select sqrt (square root).

(a) What do you observe about the image? Explain how the change in scale caused this change. [2]

Actually, the image you see does not do the data justice. This detector on the Chandra Telescope (ACIS) is
capable of identifying the energy level of the X-ray photons it collects. To see the spectrum of energy levels of
X-ray photons from Cassiopeia A, select edit → region in the buttons bar and create a circular region that
encompasses Cassiopeia A¹. Next go to Analysis in themenu bar, select Chandra-Ed Analysis Tools in the

¹Ensure that the shape is Circle under Region in themenu bar, the region button under edit will draw any shape set in themenu.
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Figure 3: X-ray image of the Cassiopeia A (central Neutron Star circled)

dropdown menu and then Quick Energy Spectrum Plot] in the submenu (Fig. 9).

Figure 4: Emission and Absorption Spectra ofHelium atoms. Credit: Nagwa, 2023

You may be aware that atoms of an element absorb and emit light characteristic to the element itself. Emission
lines are associated with the specific wavelengths of light emitted by the transitions of excited electrons from
higher to lower energy states in the atoms while absorption lines are the specific wavelengths of light absorbed
by the transitions of electrons being excited from lower to higher energy states in the atoms of an element. The
emission lines of an element’s atoms can be identified by providing a source of energy to excite electrons in the
atoms to higher energy states and recording the light emitted when these unstable electrons trickle back down to
their stable energy states; on the other hand, absorption lines are identified by providing a background source of
light in a range of continuous wavelengths and recording the light that pass through the unexcited atoms of the
element, resulting in certain wavelengths appearing dark in the spectrum as they are absorbed to excite electrons
in the atom to higher energy states (Fig. 4).

(b) The Quick Energy Spectrum Plot plots the number of photons detected within regular intervals of

energies over the entire range of energies of the photons collected (i.e., a histogram of photon energies).

How does this allow us to capture the emission and absorption lines of elements from Cassiopeia A? [1]

(c) Based on your answer in part b, identify two emission lines and their energies in the Quick Energy
Spectrum Plot. Show your working clearly. [1]

After you have analysed your energy spectrum plot and without removing the circular region, choose Energy
Filter from the same submenu under Chandra-Ed Analysis Tools. This tool allows you to only show
detected photons whose energies fall in the chosen range (Fig 5. Note that the energy values are in keV and the
lowest reasonable value is 0.1 since that marks the start of the spectrum for X-rays). You may choose an arbitrary
energy range at this point².

²Note that you should choose an energy range which has a significant photon count according to your energy spectrum plot.
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Upon choosing an energy range, the program will generate a new frame for your image, showing the photons
detected in the energy range. Select this new frame and select frame → single in the buttons bar, you can
now save this image as a FITS file under File → Save in themenu bar. After saving, you can delete this frame
(frame → delete in the buttons bar) to avoid confusing yourself. You may repeat the process of generating for
two more frames with different energy filter ranges. The goal here is to create three frames of three distinctive
energy ranges to represent the three different colours in an RGB Image.

Figure 5: The Energy Filter tool window

Next, we will create a composite image from the three frames that we have created. Go to Frame in themenu bar
and select New Frame RGB. A pop-up window will open, as shown in Fig. 6. The radio buttons under Current
represents the frame that is active. Choose Red and open an image frame you saved (File → Open in the
menu or buttons bar). You will see that the image that shows up is coloured red. You can adjust the bias and
contrast beforemoving on to highlight the features of the image. Next, select Green under Current and repeat
the process for the next image. Finally, do the same for Blue. If you would like to synchronise the changes to the
bias and contrast of all three images, go to the Lock dropdown menu and lock Colobar, you can also lock other
aspects like Scale. If you would like to modify your image after you have closed the window, you can find it
under Frame → RGB... in themenu bar.

Figure 6: RGB Frame pop-up window

(d) Identify three elements from the Quick Energy Spectrum Plot of Cassiopeia A and create an RGB

composite image of Cassiopeia A with each colour representing an element you have chosen. Mark out

the elements you have identified on the energy spectrum plot and present it as working to this part of

the question. Save your created image in SAO as an RGB Image (.fits) under File → Save As in the

menu bar. Also, save the colour image as PNG and attach it to your report (File → Save Image →
PNG...). [2]

The observation of Cassiopeia A that we have just explored was made in 2000. It has been a long time and we
have newer observational data now. Let’s see if we can notice some changes about Cassiopeia A with time. Search
for and download observation ID 19606 from Chandra X-ray Center here. Follow the steps in the Appendix
B to download the data.

Extract the folder within the .tar package file using any archivemanager (like WinRAR).
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Delete all but the original bb color frame of Cassiopeia A in SAOImage9, now create a new frame and open the
acisf19606N002_evt2.fits.gz file in the extracted folder 19606/primary. Set color to bb and apply the
appropriate scaling to make the two images look as close as possible. Set your frame to tile mode in your
buttons bar so you can look at both images simultaneously. Find a significant feature in both images that bear
resemblance. You can use the edit → cross (crosshair) in the buttons bar to help you determine the proximity
of features.

(e) Take a screenshot of the feature you have identified in each image, label them, and include your

screenshots in the report. Take the angular distance of these features from the centre star of the

Cassiopeia A (circled in Fig. 3) by drawing a Ruler region³ (take screenshots of your working). What is

the difference in angular distance from the neutron star to the feature in each image? What does this

tell you about Cassiopeia A? [2]

(f) Given that the shell of Cassiopeia A is expanding at around 5000km s
−1
. Approximate the size of

Cassiopeia A in terms of light years across. [2]

³Change the shape of the region to Ruler in themenu bar and user a region tool under edit in the buttons bar.
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3 Cosmic Rolex

2. Pulsars are rapidly rotating neutron stars that have a strong magnetic fieldmisaligned with their axes of rotation.
The rotating magnetic fields can generate beams of electromagnetic radiation pointing in the directions of the
magnetic poles of the neutron star. If these beams of radiations point towards Earth as the neutron stars rotate,
we can detect it as a pseudo-star, but with a regular period of brightness variation. These periods are often
very accurate,making the pulsars seem like cosmic clocks that can tell time. X-ray pulsars are similar but emit
most of its radiation in X-rays. X-ray pulsars are usually in binary systems with a star, siphoning material from
their companion into an accretion disk around themselves. When these stellar materials get funnelled into the
magnetic poles of the X-ray pulsar, they heat up immensely and release radiation in the X-ray spectrum. Cen
X-3 is an X-ray pulsar in Centaurus and our next object of interest.

You can save your file from the previous section as a FITS file, close your DS9, and reopen it. From the Virtual
Observatory database which we accessed previously, find and openObs Id 19434.

Figure 7: Image of Cen-X3

Change the color to He and the scale to min max and linear. You should get something like what is shown
in Fig. 8. Do not delete any regions in the image. If you do, reload the data from the Virtual Observatory.
These streaks are not features of the object itself but diffraction spikes due to the gratings used to analyse the
spectroscopic frequencies of the target object in the Chandra Telescope. Hence, we need to include these streaks
as regions in our analysis.

Without adding or deleting any regions, conduct a Quick Energy Spectrum Analysis under Chandra-Ed
Analysis Tools in the Analysis menu. In the pop-up graph plot, save the plot data under File → List
Data and save as .txt format (Make sure to save it as a “filename.txt”, and not just “filename”).

In your listed data, you will see three columns. The first is the energy of the photon received, the second is the
number of photons received, and the third is the uncertainty of themeasurement.

Import the data into Excel, sum up the total energy fromX-ray photons received by the telescope in this exposure
and the total number of photons received. Refer to Appendix C if you need help with import .txt data into
Excel.

(a) Calculate the average energy of a photon that the detector received. [0.5]

(b) Given that the average photon count when the X-ray beam from Cen X-3 is facing us is 78.8596 per

second and the effective aperture of the Chandra X-rayObservatory has an area of 353 cm
2
, calculate

the apparent bolometricmagnitude of Cen X-3 when it is the brightest, assuming Cen X-3 emits most

of its energy in X-ray. You may reference the intensity of radiation from a celestial source with a konwn

apparent magnitude. [1.5]

4Pleasemake sure that after clicking on the link to download the data, you can see all the printouts in Fig. 10. and that the file you have

downloaded is cenx3.fits and not 1943.fits. You can search for “1943” using CTRL-F (make sure you have clicked on the internal browser

page so that the page is recording your inputs) and CTRL-G after the text is highlighted to cycle to the first search result at the top of the page.
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Without adding or deleting any regions, create a light curve with FTOOLS/Light Curve under Chandra-Ed
Analysis Tools (Analysis menu bar, Fig. 9). Zoom in on the plot generated by drawing a rectangle with
your mouse around the area to zoom in to. Do so until you can see the clear periodic variations in the X-ray
brightness of the object.

(c) Take a screenshot of your plot andmeasure the period of brightness oscillation. Show your working on

your screenshot. [1]

(d) Based on information from the light curve only, do you expect the radiation received to be from a small,

concentrated source (e.g., a small star), or a large extended one (e.g., a nebula/gas cloud)? Explain. [1]

Now open another tool: FTOOLS/Power Spectrum under Chandra-Ed Analysis Tools. The peaks in this
plot show the frequencies that best fit the time variations in the data. Zoom in on the peak, what do you notice,
does the frequency correspond to the period you have calculated in part c)?

You may have noticed that there is not just a singular dominant frequency, but several, and the peak tapers off on
both sides. This is due to the orbital motion of Cen-X3 around its companion, which results in doppler shift of
the X-ray pulses we receive from the pulsar.

(e) Explain how doppler shift results in this distribution of the observed frequencies of the pulsar’s rotation. [1]

(f) With information from the power spectrum plot, find themaximum andminimum doppler-shifted

frequency of the rotation of the Cen-X3. Hence, find themaximum radial velocity of Cen-X3. Include

your working on a screenshot of the power spectrum plot. [2]

By observing the change in the doppler-shifted rotational period of Cen-X3 and the periodic dimming of the
pulsar when it is eclipsed by its companion star, we can determine the orbital period of Cen X-3 to be 2.1 days.
Since Cen-X3’s companion is an optical supergiant star, we can measure its radial velocity through spectroscopy
and find its maximum radial velocity to be 26 kms−1. Furthermore, by observing the eclipse of Cen-X3 by its
supergiant companion, we have obtained the orbital inclination of the binary pair to be 70 degrees5.

(g) Hence, calculate themass of the binary system of Cen-X3, give your answer in solar masses.

HINT: Use Kepler’s third law for binary systems. [2]

(h) What is themass of the Cen-X3 and its companion star respectively? [1]

5An edge-on orbit has an orbital inclination of 90 degrees with respect to us.
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A Using SAOImageDS9

Figure 8: The SAOImage 9 interface

1. Menu bar: Provides access to all ds9’s features.

2. Information panel: Displays information about the values at the cursor position and the data file.

(a) Object: Object name loaded from the header of the data file

(b) Value: Number of photons that hit the sensor at that pixel, i.e., brightness of the pixel.

(c) FK5: Celestial Coordinates of the cursor position according to the reference stars of the Fifth Fundamental
Catalogue. RA and Dec values are in hours:minutes:seconds

(d) Physical: Pixel coordinate with respect to the CCD camera (different from “Image” coordinates if the image
shown is part of a larger image)

(e) Image: Pixel coordinate with respect to the image, the coordinates are with respect to the centre of each
pixels. Bottom-left of the bottom-left pixel of an unrotated image is assigned a coordinate of (0.5,0.5).

3. Panner: A cyan rectangle that can be dragged around the image to view its parts. Also shows the cardinal
directions and image axes.

4. Magnifier: Shows amagnified view of what the cursor is hovering over.
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5. Buttons: Duplicates many of the options found in themenu bar. Choose a category from the top row to view the
options on the bottom row in that category. In Fig. 1, the “color” category is chosen and “grey” is selected from
the options.

6. Display frame: Area where the FITS image is shown. A single frame is shown in Fig. 1. Multiple frames can be
opened, more operations and options with frames are shown under the drop-down menu for “Frame” in the
menu bar and under “frame” in the buttons bar.

7. Colorbar: Displays the colormap, bias, and contrast settings. To change the colormap, use the “Color” menu
or button. The contrast and bias can be adjusted by holding down right-click and dragging on the ds9 display
(up-down and left-right respectively). The Color → Colormap Parameters dialog box can also be used to
change the contrast and bias.

You can save all your settings and preferences by opening Edit → Preferences dialog box.

Navigation Tips

1. Zoom button→ Zoom Fit when you are out of frame

2. When using the Pan tool (Edit button→ Pan), click towards where you want to go, not drag.

3. Use the arrow keys on your keyboard to move themouse one pixel in the specified direction.

Chandra-Ed Analysis Tools

Figure 9: Submenu of Chandra-Ed Analysis Tools. Credit: SAOImageDS9, 2009

Frames

Frames allow DS9 to displaymultiple images at once and also allow you to work with multiple images at once. To
create a new frame, click on either Frame in themenu bar and New Frame, or the frame button and new. You may
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not be able to see your frame at first, that’s because you are in the single framemode. Change your mode in the
buttons bar under frame or under Frame in themenu. The availablemodes and their functionalities are listed below:

Single Frame: shows one frame in the window at one time, you can move to the next frame by pressing tab on your
keyboard or next and back in the buttons bar under frame.

Tile Frames: shows you all the available frames in a tiled format, the frame in which you are working will be
highlighted with a blue border. To change between frames, press "tab" on your keyboard or click on the frame
you would like to go to.

Blink Frames: switches between the frames periodically, showing only one frame at a time in the window.

Page 11 of 14 [Turn over]



AstroChallenge 2023 Senior Data Analysis Round

B Downloading data fromChandraX-rayCenter

1. Enter the desired Observation ID into the search field, followed by pressing the search button.

2. Make sure the result that you would like to download is selected with the blue check mark. We will only be using
the primary data package for our analysis, uncheck "Secondary package". Click the “Add Products to Retrieval
List” button.

3. Click “Retrieve Products”.

4. Follow the instructions of the page to retrieve your downloadable file. You may need to refresh the page provided
by the given link a few times before your file shows up. The file you would have downloaded should be in the
.tar format; this is an archive format, similar to .zip or .rar.
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C Importing txt file into Excel

When you open a .txt file that contains a table like format, Excel will try to interpret it as one. You will bemet with
the Text Import Wizard. Follow the following steps.

1. Select "Delimited".

2. Next.

3. Check "Space".

4. Next.

5. Select "General".

6. Finish.
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Cen X-3 Virtual Observatory printouts

Figure 10: Correct printouts after downloading the observation data for Question 2
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